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Exercise 3-1: Creating a soil property map

Mapping objectives:
o Create a soil analysis point layer from tabular data in (GIS
o Create a continuous surface soil property map using Kriging Interpolation in SAGA GIS 6.2.0
o [esign a grid sampling scheme

Data folder: Dataset3
) F26_Boundary_UTM.dbf
F26_Boundary_UTM.prj
F26_Boundary_UTM.gpj
F26_Boundary_UTM.shp
F26_Boundary_UTM.shx
F26_SoilAnalysis_2014.txt

long'term release

QGIS 3.4

Open 0GIS 3.4.11 with GRASS 7.6.1 0
*
A\

QGIS Desktop 3.4.11 with GRASS 7.6.1 Madeira
App

Part 1: Open a project
1. Create a new project in QGIS
a.  Goto Manage Layers Toolbar, click Add vector layer to add F26_Boundary_UTM.shp into the project

s Add vector layer

| Source type
@ File Directory Database Protocol
Encoding | System s
Source

Dataset 3_Tutorial\Data\dataset3\F26_Boundary_UTM.shp Browse

Open Cancel Help

Part 2: Create a soil analysis point layer from tabular data
1. Click Add Delimited Text Layer in Manage Layers Toolbar
2. Click Browse to select F26_SoilAnalysis_2014.txt and set other parameters as follows. Then click 0K
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iy Create a Layer from a Delimited Text File ? -

File Name 1/Ongoing_tasks/171214_QGIS_F26_Tutorial/Data/dataset3/F26_SoilAnalysis_2014.tbxt

Layer name | F26_SoilAnalysis_2014 Encoding | UTF-8 -

File format CSV (comma separated values) @ Custom delimiters Regular expression delimiter
: Comma X Tab Space Colon Semicolon ‘
!Dther delimiters Quote | " Escape "

Record options Number of header lines to discard 0 2 X First record has field names

Field options Trim fields Discard empty fields Decimal separator is comma

Geometry definition @ Point coordinates Well known text (WKT) Mo geometry (attribute only table)
X field | Longitude v Y field | Latitude o DMS coordinates

Layer settings Use spatial index Use subset index Watch file

| SamplelD I Longitude I Latitude | Clay_% | Silt_% | Sand_% SDM_%I pH | Lime_index | P_ppmﬂ

b il _"-73.939319“i45.415785.?_23 _"41 “36 “63.3 _"6.9 .?_69 .I.?'S =

|2 |2 |-73.930637 | 45.417081 13 |25 |62 |7.8 |59 |64 |140 B

[«] | [«

0K Cancel Help

~ % ] F26_Boundary_UTM
¥ @ F26 SoilAnalysis 2014 UTM
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Processing Toolbox £
e OB B X%

| &I reﬁacturl a |
= {1 Recently used

1'%?':' Refactor fields
* [} Vector table

Refactor fields

6. Change the type of field:

a. Type “refactor” in processing
Toolbox and open “Refactor
fields".

b. Select "F26_SoilAnalysis_2014"
shapefile.

¢. change all string type to
“Double”.

d. click "Run”
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'G! Refactor Fields s
b
Parameters | Log Refactor fields
Inputla
b ==t This algorithm allows editing
o F25_soilanalysis_2014 UTM [EP5G:32618] - | [ ... | 2 | the structure of the atiributes
== table of & vector layer, Fields
| selectad features anly can be modified in their type
: fields
Fields mapping Type
L | Field name | EEE [ Length | Precision = |E| Couble - | iz ot
| | e yeris
0 v | € |sampieid  |Double -1 254 o [ fooute  + feontainsa
[T — table,
ATl | | £ |L|:rngitude Double - | 254 0 |‘| Double - | rovided
2 -| £ | Latitude Double -| 254 0 ||| |Double - |
3 |~ | | £ |Clay_% Double -1 254 0 [au| |Doutle - |
|~ || & |sit% Double -1 254 0 Double  ~ |
5 |~ || € [sand % Double | 254 0 pae. ¥
6 = | £ 50M_% Double - | 254 0f
:1 - (I u 2 *..
Load fields from layer |~ Clipped ~ || LoadFields |
Refactored
|[Create temporary layer] | | al
|| Open output file after running algorithm
| 0% | Cancel
|Run as Batch Process... | I Fun I | Close [ Help |

v ® Refactored |
V| ® F26_Yield_Soybeans_2014
v [ | F26_Boundary_UTM
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3. InLayer Panel, right click Refactoraed, then click Save As
4. In Save vector layer

a. Format = ESRI Shapefile

b.  File name = F26_SoilAnalysis_2014_UTM.shp

c.  CRS=Project CRS (EPSG:32618 - WGS 84 / UTM zane 18 N) Click 0K
5. Right click F26_SoilAnalysis_2014 and Refactoraed then click Remove

Part 3: Create an interpolated soil property raster layer using SAGA GIS software
1. Launch SAGA GIS 6.2.0

WWW.Sa93-9Is.0rg

Tocls | 52 Data | i Maps |
B Tocl Libraries

Ep% Climatc

[ Garden

A Grid

-4 Grd Collcction
i1 4@ Imagery
m* [mport/Export
|I| Q Projection

| - Reports

LCata Sources
] FileSystem | §g CDBC | & PosigreSQL|
—a Lol Disk (C:]
g Local sk L]

b

2Lt DVD RW Drive (E)
L) €D Drive (G) WD SmartWare LRSI %
3 Ademchuk_passport (H:) @ General |ﬁ Exccution | O E"ﬂr5|
[2018-01-25/14:15:18] Loadtool chan: :ocshodlckaing®ta_TrawelT mesnl.. okay -
(3
|Recognzed Files - -
reacy || || o

2. Import F26_Boundary-UTM.shp and F26_SoilAnalysis_2014_UTM.shp into SAGA
a. InData Source > File system, navigate to the project folder and double click on F26_Boundary-UTM.shp and

F26_SoilAnalysis_2014_UTM.shp to add these two layers to Data > Tree
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P
& shGA

(o[ o s

essing

File Geof ?
o HE2E0) ) 2

i Manager

® Tools| 32 Data |[E) Maps|

Q Data
-3k Shapes
p— -
I = %= Point
| e%% O1.F26 SoilAnalyfs 2014 UTM
E|‘U' Polygon
7% 01, F26_BoundaryuTM

t Data Sources
|| & File System | & oosc| &

-1 | F26_Boundary_UTM.db
[~ F26_Boundary_UTM.sh
.| F26_SoilAnalysis_2014 6

[~ F26_ScilAnalysis_2014_UTM.dbf

i ] G‘enelal |ﬂ El:ecuﬁonl (1] Elmrs|

[21018-01-25/14:15:18] Load tool chain: toolsMtoolchaingitta_TravelT ime.xml...ckay -
k% [2018-01-25/14:58-24] Load shapes: D:\Google Drive'\Research\Ongoing_tasks\180123
3 _QIGIS_F26_TutoriahD ata\dataset3F26_Boundary_UTH shp..okay Ij‘
= = [21018-01-25/14:58:36] Load shapes: D:\Google Drive\ResearchyOngoing_tasks4180123
Recognized Files '] _OGIS_F26_TutoriahData\dataset BF26_Soildnalysis_2014_UTM.shp...okay <
ready k d ;

%

3. InMain Manu, go to Geoprocessing > Grid > Grid System > Create Grid System

File | Geoprocessing | Window 7
i Load Tool Library
Mana, Find and Run Tool x
i .
Climate r
Database »
File »
Garden »
Grid v Analysis
inwgery » Caleulus
Projection 3 Distances
— Shapes » Filter
Data § Simulation » Gaps
E Spatial and Geostatistics * Grid Systermn Aggregate
| TIN » Gridding Clip Grids
Table , Values Clip Grids [interactive
] Terrain Analysis v Visualisation Create Grid System
: R == e T T T I i i Tk

4. InCreate G}id S;/st:en-ﬁ:

Use default values, with the following exceptions:

a. Cellsize=5

b.  Extent Definition = one or more shapes layers

. Adjust = extent to cell size

d. Data Objects > Shapes > Sahpes Layers = 1object (F26_Boundary_UTM), click Okay




-
Create Grid System
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]

£ Options
Olkay
Initialization Value 0
Cetisize 5
Extent Definition one or more shapes layers
Adjust extent to cell size
| Use Offset = Load
l 1
= Data Objects
Save
S | sae |
>> Shapes Layers 1 object (F26_Boundary_UTM) (=)
i ‘>> Shapes Layers ‘
L e ;
Shape(s) -

Manager X

%z Tools| & Data | Maps

01. F26_SoilAnalysis_2014_UTN

K

p1. F26_Boundary UTM |

Okay

M

=

Jow

5

Cancel

Tree | B8 Thumbnails|
& Data
=8 Grids
- O 5; 81x 87y; 582902.606307x 5029571.127338y
- LEH01. Dummy Grid
EE= Shapes
E- %= Point
- L% 01. F26_SoilAnalysis_2014_UTM
=4} Polygon
47} 01. F26_Boundary_UTM

.

6.

Go to Manager > Tools > Spatial and Geostatistics - Kriging > Ordinary Kriging. Double click on this tool to open the

Manager

*g: Tools = Dml@ Maps

|_:_|Q Spatial and Geostatistics
-4 Grids

B@ Kriging
H I Ordinary Kriging

E egression RNging
%y Simple Kriging
% Universal Kriging
% Variogram (Dialog)
G Points

Shapes > Points = 01. F26_SoilAnalysis_2014_UTM

Options > Target Grid system = grid or grid system
Grid system=5; 81x87y; 582902.606307x5029571.127338y

dialog window
In Ordinary Kriging:
Use the default values, except for the following:
a. Data Objects
Attribute = pH
b.
<< Prediction = <create>
. Search Options

Search Range = global
Number of Points = all po

ints within search distance
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Click Okay
In Grids > Grid System, use the drop down arrow to select

( ™
—— [ emm
B [ oy ]

pes
=l »> Points 01. F26_SoilAnalysis_2014_UTM
Attribute pH
= Options
| = Target Grid System grid or grid system Load
= Grid System 5: 81x B7y: 582002.606307x 5029571127338y
Sav
<< Prediction <create>
< Quality Measure <not set>»
= Kriging
Type of Quality Measure Standard Deviation
Logarithmic Transformation 0
Block Kriging 0
Cross Walidation none
=l Search Options
Search Range global
Number of Points all points within search distance EI 1
Number of Points
Choice
Available Choices:
[0] maximum number of nearest points
[11.all noints within search distance

7. InVariogram:
Use default values, except ...

Under the variogram plot, replace the variables with values:
n (nugget) = 0.06; s (sill) = 0.25; r (range) = 210
So, the spherical model of pH =
0.06 +(0.25 - 0.06) * ifelse(x > 210, 1, 1.5 *x / 210 - 0.5 * x*3 / 21073) [Press Enter key]
Click Ok
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[ ok |
. .
[ Cancel | 0z
Settin . [
\ o | —
[Number of Pairs =
Predefined Functions oz L
S RTINS T T .
Function Fitting Range o
0 Ao /
- 0.8
—
.
Function Parameters /
0,06+ (0.25 - 0.06) * ifelse(x > 210, 1, 1.5 x/ o
210- 0.57x*3/ 21043)
» .
87.73% g [om
261974327 2
o >
9 012
3249
istance: 261.97 N
0.10
008
004
002
00 [0 |m | |« @ |n |o |o |00 [m [m [w |w | [e0 [m0 |w [0 |20 |20 |20 |m0 |2

Distance

0.06 + (0.25 - 0.06) * ifelse(x > 210, 1, 1.5*x/ 210- 0.5 * x3 / 210*3)

9.

8. In Manager > Data, double click 02. F26_SoilAnalysis_2014_UTM.pH [Ordinary Kriging]

e

& SAGA

File Geoprocessing Window ?

= (D2 E0) =] 7

Manager

|% Tools| & Data I@ Maps|

Tree | B4 Thumbnails|

= Data

0Dy Grid
l 02, F26_50i IAnalysis_Zﬂlfl_UTMl
o-52 Sh apes

< : I | 3

-

£1-HEg Grids
- =-J 5;81x87y; 582902.606307x 5029571 =

Data Sources

File System | &3 ODBC | &2 PostgresQL|

- temp

[~ | F26_Boundary_UTM.dbf

=] F26_Boundary UTM.shp

| F26_SoilAnalysis_2014 bt

=] F26_SoilAnalysis_2014_UTM.dbf
D F26_SoilAnalysis_2014_UTM.shp

: [ ¥ cnrd
I [ 1 | 3

mmmmmtmm|mm

[ 02. F26_SeilAnalysis_2014_UTM.pH [Ordinary Kr.. | = |[ @ |[ £ |

ro
e

[

(029600 SE'IZQEEEI AG0207G0 5020840 5029920 5030

T
29680 5029760 S0Z0840 5020920 5030

G

T
F029600 &

T T T T T T
mmmmmtmm|mm

m

Recognized Files

-

[2018-01-25/15:24:59] T ool execution succeeded

Mezsages =
@ General Q Euecu’(ionl O Erors

[2018-01-25/15:02:27] Tool execution succesded -
[201 8-01-25/15:12:25] Executing toal: Ordinary Kriging

ready

X 583230.435254

¥ 5020665.929969 Z7.093857288361 |

Right click 02. F26_SoilAnalysis_2014_UTM.pH [Ordinary Kriging] to save the file as pH.sgrd

10. Repeat steps b - 8 to interpolate soil property of K_ppm, P/Al_ratio, SOM_%, and Lime_index, and then save them as
K_sgrd, P_Al.sgrd,, SOM.sgrd and lime_index.sgrd respectively
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Attribute Spherical model Function Fitting Range
K_ppm 0+(2600 - 0) * ifelse(x > 150, 1,1.5 * x / 150 - 0.5 * x3 / 150"3) 60
P/Al 0+ (340 - 0) * ifelse(x > 160, 1, 1.5 * x /160 - 0.5 * x3 / 160"3) 80
Lime_index | 2.5 +(6.8 - 2.5) * ifelse(x > 200, 1, 1.5 * x / 200 - 0.5 * xA3 / 200"3) 100
SOM_% 0+(520 - 0) * ifelse(x > 150, 1, 1.5 * x / 150 - 0.5 * x*3 / 150"3) 100
I #

N —

.

-

[ o

[Ty e .

[

i

P/Al_ratio Lime_index

FEEpEErr=r T

(d
1
|

i
I
l

Part 4: View the interpolated soil property maps in QGIS

1. Back to QGIS interface, double click pH.sdat in Browser Panel to add this layer into Layers Panel
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Browser Panel @E]

B e T®Eo

El- | dataset3 [«]
- data

-2 F26_Boundary_UTM.shp
-3 F26_SoilAnalysis_2014.bd¢
=] F26_SoilAnalysis_2014_UTM.shp

SOM.sdat
-~ set3.qgs

i ent2 1 anc

X @ F26_SoilAnalysis_2014_UTM

2. InMenu Bar, go to Raster > Extraction > Clipper ...
a. Input file (rater)= pH
b. Outputfile =pH_c
c.  Clipping mode = Mask layer
Mask layer = F26_Boundary_UTM
Keep resolution of input raster
a. Load into canvas when finished
Click OK
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Create an output alpha band

® Keep resolution of input raster

X Load into canvas when finished

gdalwarp -q -cutline "D:/Google

"D:/Google

Drive/Research/Ongoing_tasks/171214 QGIS_F26_Tutorial/Data

iy Clipper
Input file (raster) | pH |~ Select...
Output file 6_Tutorial/Data/dataset3/pH_c.tif = Select..
| No data value [0 =
Clipping mode
Extent ® Mask layer
Mask layer FZE-__EoundE!ry_UT_M i Select...

Crop the extent of the target dataset to the extent of the cutline

Set output file resolution

[~] D

Drive/Research/Ongoing_tasks/171214 QGIS_F26_Tutorial/Data D
/dataset3/F26_Boundary_UTM.shp" -tr 5.0 5.0 -of GTiff

11 &)
) —
&

Close Help
3. InLayers Panel, right click pH layer and click Remove
4. In Layers Panel, right click pH_c layer and click Properties
a. InStyle:
Render type = g .
Singleband pseudacolor \ CETEECNE
b. Load min/max values \ fod ¥ Band rendering

Interpolation = Liner
Color = Blues;

Check Invert

Mode = Equal interval;

|.ﬂ Transparency

ﬁ Pyramids

Classes = ]0 = Histogram
Click Classify @i
Click OK :

Legend

Render type  Singleband pseudocolor | ¥

Band Band 1 (Gray) -
Min 60968? Max ?3?’401
b Load min/max values
Interpolation  Linear -
Color D [ - Edit X Invert
Label unit
suffix
M .'I MEX Etmated cmulative cut of ful extent,
origin:

Color  |Label

Mode Egualinterval v

Style T

Classes (10 |5

Cance|

Apply

r

Help

[*]

ED
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X @ F26_SoilAnalysis_2014_UTM
P 4 F26_Boundary_UTM
=- (X pH c
- 5.815
6.251
6.409
6.538
6.689
6.826
6.955
7.004
7.281
7.51

5. Rename each layer for a better layout
a. Right click pH_c to rename this layer as Soil pH
b.  Right click F26_Boundary_UTM to rename this layer as Boundary
c.  Right click F26_SoilAnalysis_2014_UTM to rename this layer as Soil Sampling

X @ soil Sampling
- [ Boundary
= [ Soil pH
5.815
6.251
6.409
6.538
6.689
6.826
6.955
7.094
7.281
7.51

Part 5: Create a soil pH layout map
1. InMain Menu, click Project > New Print Composer, and name this Iaéout as Soil pH. Click OK

/ Compose.. ?

Create unique print composer title
(title generated if left empty)

[ Sail pH |+

2. Click Add new map and draw a rectangular area in the layout

=@ &l

Scale = 2500
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(4

A

‘Composer Edit View

B X

OPHERLUsnEmARARE Bl ¢l [*den® 8RR
. |2|59\||I\||||‘3?0|¢
[~]

‘9
e e A

n|‘

Layout Atlas Settings

LEITYEE

150

|50 ‘100
e S e e e

Soil pH
e pLR

200

150| mn‘ 50
oty O s ) (O OO Tt Ok O 0 O (GO

200

Compos...

Map 0

Cache

Scale

Map rotation

¥ Layers

Follow vi

¥ Extents

[ [

e

[(£]+]

% 288.483 mm y: 0 mm

page: 1 51.1%

~  1item selected

¥ Main properties

X Draw map canvas items

Lock layers

[ Lock styles for layers

X min  582861.903
Y min | 5029565.840
X max 583349.403

¥ max | 5030015.840

View extent in map canvas

.
!

Item prope...
!

Atlas gener.. | .

Ttem properties

¥ | Update preview
L=
1a

2500

0.00 @

sibility preset  (none)

[« &

gl

Set to map canvas extent

3.
b,

6.
a.
1.

Use move item content to adjust the view of map
Add legend, title, and scalebar to the map using:

Id =
A

Add new label

Add Legend

Add nort

Go to Composer > Export as Image...

File name = soil_pH-map.png

Save the project as set3.qgs

h arrow

\©

Add Scalebar

Field 26

Variability of Soil pH

Legend

® Sail Sampling
Oeoundary
Soil pH
| B
| [#isl
B s 403
[ =
o ¥
ez
= X144
7o
drzet
s

% 0 25 50 75 #00m
)




